TUCoPS :: Linux :: Gentoo :: b06-4081.htm

x11vnc: Authentication bypass in included LibVNCServer code

Better a bottle in front of me than a frontal lobotomy.

x11vnc: Authentication bypass in included LibVNCServer code
x11vnc: Authentication bypass in included LibVNCServer code



--nextPart1467121.XMqcyPoyF1
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200608-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: x11vnc: Authentication bypass in included LibVNCServer code
      Date: August 07, 2006
      Bugs: #142559
        ID: 200608-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
VNC servers created with x11vnc accept insecure protocol types, even
when the server does not offer it, resulting in the possibility of
unauthorized access to the server.

Background
=========
x11vnc provides VNC servers for X displays.

Affected packages
================
    -------------------------------------------------------------------
     Package          /  Vulnerable  /                      Unaffected
    -------------------------------------------------------------------
  1  x11-misc/x11vnc       < 0.8.1                            >= 0.8.1

Description
==========
x11vnc includes vulnerable LibVNCServer code, which fails to properly
validate protocol types effectively letting users decide what protocol
to use, such as "Type 1 - None" (GLSA-200608-05). x11vnc will accept
this security type, even if it is not offered by the server.

Impact
=====
An attacker could exploit this vulnerability to gain unauthorized
access with the privileges of the user running the VNC server.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All x11vnc users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=x11-misc/x11vnc-0.8.1"

References
=========
  [ 1 ] CVE-2006-2450
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2450 
  [ 2 ] GLSA-200608-05
http://www.gentoo.org/security/en/glsa/glsa-200608-05.xml 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200608-12.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 

--nextPart1467121.XMqcyPoyF1
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBE14AzzKC5hMHO6rkRAmIPAJ9IoaE/+WOpzx5asvWqKAMXlDzgPwCeN0th
Y7BWjoXLQaj4d/wnSA/nopk=lQR9
-----END PGP SIGNATURE-----

--nextPart1467121.XMqcyPoyF1--


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH