TUCoPS :: Linux :: Gentoo :: bx1687.htm

GOffice: Multiple vulnerabilities

Better a bottle in front of me than a frontal lobotomy.

GOffice: Multiple vulnerabilities
GOffice: Multiple vulnerabilities



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200801-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: GOffice: Multiple vulnerabilities
      Date: January 30, 2008
      Bugs: #198385
        ID: 200801-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple vulnerabilities in GOffice could result in the execution of
arbitrary code.

Background
=========
GOffice is a library of document-centric objects and utilities based on
GTK.

Affected packages
================
    -------------------------------------------------------------------
     Package           /  Vulnerable  /                     Unaffected
    -------------------------------------------------------------------
  1  x11-libs/goffice       < 0.6.1                           >= 0.6.1
                                                             *>= 0.4.3

Description
==========
GOffice includes a copy of PCRE which is vulnerable to multiple buffer
overflows and memory corruptions vulnerabilities (GLSA 200711-30).

Impact
=====
An attacker could entice a user to open specially crafted documents
with GOffice, which could possibly lead to the execution of arbitrary
code, a Denial of Service or the disclosure of sensitive information.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All GOffice 0.4.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=x11-libs/goffice-0.4.3"

All GOffice 0.6.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=x11-libs/goffice-0.6.1"

References
=========
  [ 1 ] GLSA-200711-30
http://www.gentoo.org/security/en/glsa/glsa-200711-30.xml 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200801-19.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org 

iD8DBQFHoP2EuhJ+ozIKI5gRAjzHAJ9d1G3+2yNqs8rTR/mFPXa6zkP15ACcCwzT
A915QobQAhgbR3fy0EjPEog=HCW7
-----END PGP SIGNATURE-----


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH